Speed-Talk is running on www.Speed-Talk.com

IMPORTANT: Update your bookmarks to https://www.speed-talk.com/forum/
(Right-click the URL and select "Bookmark this link")

79 El camino rear brakes not working

Shocks, Springs, Brakes, Frame, Body Work, etc

Moderator: Team

Post Reply
rfoll
Guru
Guru
Posts: 2786
Joined: Mon Jan 11, 2010 12:44 pm
Location: St. Helens, OR

79 El camino rear brakes not working

Post by rfoll »

When I got this car the brakes were shot. When I hit the brakes, the left rear wheel would lock up but the right did nothing. I put new rotors and pads on the front, and new cylinders and shoes on the back. I pressure bled the system from the master cylinder to remove the nasty old fluid and remove air. Now the rear brakes don't work at all. I re-bled the system again and had someone apply the brakes while I opened the rear bleeders. It squirted fluid like one would expect, indicating the master cylinder was pumping fluid. There is no air in the lines. I saw a bleeder tool online that you install in the proportioning/combination valve to keep it stationary while the system is bleed. Is it possible that the internals have shuttled to one end and and not returned to center or something of that order? If so, can it be corrected? The warning light works while the bleeding is happening, but goes out when the job is finished. Finding a stock replacement is difficult, everyone wants to sell you a generic piece that requires adapter fittings. Curiously, my 71 C20 does nearly the opposite, It locks up the rear brakes until it has been driven for a few stops. What is the likelihood that these things can be successfully disassembled and cleaned up? Thanks, Rick
So much to do, so little time...
BigBlocksOnTop2
Pro
Pro
Posts: 492
Joined: Thu Mar 21, 2013 12:03 pm
Location: Chancellorsville Battle Field, Chancellorsville, Virginia

Re: 79 El camino rear brakes not working

Post by BigBlocksOnTop2 »

Rig up a pressure gauge and see what the psi is. Is the master cylinder new. You said removed nasty old fluid. It could be an internal leak in the master cylinder from corrosion ( brake fluid is hydroscopic and will take on moisture). Gravity bleed while maintaining level in the master cylinder starting with the wheel cylinder that is the farthest from master cylinder. I myself have been down the road and thought I had all the air out. It is easy to aerate brake fluid. Gravity bleed wont aerate. Hope some of this helps.
rfoll
Guru
Guru
Posts: 2786
Joined: Mon Jan 11, 2010 12:44 pm
Location: St. Helens, OR

Re: 79 El camino rear brakes not working

Post by rfoll »

I have been using a pressure bleeder to bleed the system, about 10 psi seems to do the trick. An internet search told me that the prop valve will indeed shuttle and hang if the system sees a loss of fluid at the rear. The rear slave cylinders were leaking some, and sure enough when removed the valve was stuck to shut off the rear system. What I don't understand is how I could bleed the rear in that situation. I replace the prop valve with a new one, and the problem persists. I am at a loss here.
So much to do, so little time...
econo racer
Expert
Expert
Posts: 715
Joined: Mon Nov 26, 2007 11:44 pm
Location:

Re: 79 El camino rear brakes not working

Post by econo racer »

Did you fix it yet? I would replace the rubber line above the rear housing. I think it has collapsed inside. Mine did this. It is cheap to try.
Geoff2
Guru
Guru
Posts: 1736
Joined: Mon Nov 09, 2015 4:36 pm
Location: Australia

Re: 79 El camino rear brakes not working

Post by Geoff2 »

Back to basics. Jack up the rear wheels, park brake off, have someone push on the brake pedal. See if you can turn the wheels. If they are locked, then that indicates fluid is getting to the wheel cyl. However the wheel cyl could have rusted internally, limiting piston travel & soaking up line pressure. New wheel cyls are usually pretty cheap.
rfoll
Guru
Guru
Posts: 2786
Joined: Mon Jan 11, 2010 12:44 pm
Location: St. Helens, OR

Re: 79 El camino rear brakes not working

Post by rfoll »

I finally found it. I cleaned the master cylinder, and they work fine now. Apparently there was just enough debris to stop the brakes from responding to a rapid pedal action, but not enough blockage to keep the fluid from locking up the brakes when tested stationary. The fact that the master cylinder worked fine before the brake rebuild made me suspect it only after all other possibilities were exhausted.
So much to do, so little time...
jake197000
Expert
Expert
Posts: 514
Joined: Sun Mar 18, 2012 11:37 pm
Location:

Re: 79 El camino rear brakes not working

Post by jake197000 »

I have never had the proportioning valve do that in 47 years,maybe replaced 1 or 2 because of leaks.as far as I'm concerned gravity bleeding is a waste of time.some times we have to bleeding the master cylinder if the system was run dry.
1980RS
Expert
Expert
Posts: 986
Joined: Thu Oct 13, 2016 10:03 am
Location:

Re: 79 El camino rear brakes not working

Post by 1980RS »

I have had a couple of proportioning valves fail in cars that I have owned. I have also put in several of them at the dealers I used to work at, biggest symptom was the Red brake light in the dash would not go out and when you bleed the rear brakes the fluid would not come out as the valve is all the way over to one side. Now I just use an adjustable valve, much better.
Post Reply